We are working on adding a new server location.
Incident Report for Calyr
Resolved
We have worked on the Server and will be updating Server Location ASAP!
Posted Apr 24, 2020 - 17:37 UTC
Monitoring
We are working on adding a new server location and will be back up shortly
Posted Apr 24, 2020 - 16:09 UTC
This incident affected: Join.Calyr.Online Infrastructure (join.calyr.online).